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Last updated 6 SEPTEMBER 2021 Microsoft Excel essentials 
DIGITAL SKILLS 

This document covers some of the key features of Microsoft Excel. Note that some of the instructions provided 
may differ slightly for different versions of the software, so for detailed instructions on any of the concepts 
covered for a different version of Excel (or for anything else), you may like to try searching the name of the 
concept using your preferred search engine.  
 
1. Creating a new workbook 

When you open up Excel you will see that you have a range of preformatted documents to choose from. A 
blank workbook will likely be the most common template that you will use; however, you may like to 
experiment with other types as you continue using the software (note: a workbook refers to the whole 
Excel file/document, and sheets are the separate pages you can use within that document).  
 
In this document we will be using an existing workbook, called Party_Budget (note there are two versions, 
Workbook_1 and Workbook_2, depending on whether you want to apply the formatting covered in 
Section 2 yourself or not). The Party_Budget spreadsheet has been organised so that each column 
represents a field (category of information; in this case name and type of item, supplier, cost and date 
paid) and each row represents a record (collection of information about a particular person, place, event 
or thing; in this case party expense). Where possible, you should ensure that you organise your data in the 
same way. 

 
2. Formatting your workbook 

When you create a new Excel workbook, or when you inherit one, there are a few things you might want 
to do in terms of formatting the document to make the data easier to interpret and understand. This 
section details a few of the key types of formatting you may wish to do, and which you should work 
through if you are using Party_Budget_Workbook_1 (which has very little formatting!). 

 
2.1 Adding headers 

The data in the Party_Budget sheet currently does not have any headings. Let’s add some so we can easily 
tell what data we are looking at. Firstly, we will need to insert a new row. To do this, right click on the 
number 1 of your spreadsheet, and click Insert (you can also find insert options in the Cells section of the 
Home tab). Now that you have a new row, we can add our headings. From left to right, in separate cells, 
type the following: 
ITEM 
TYPE 
SUPPLIER 
AMOUNT_PAID 
DATE_PAID 
AMOUNT_OWING 
 
Press the tab key or the left and right arrow keys to quickly move between cells. 
Your spreadsheet should now look like this:  

 
 
You can format these headings so that they stand out from the rest of the data, by changing the  
style (e.g. bold, italic), colour, and background fill. These options can all be found in the Font section of the 
Home tab. Play around with them to get your sheet looking how you want it.  
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At this point it is worth noting that many of these formatting changes will only be recognised by humans, 
and that there are limits to what Excel will pick up on. For example, while you can sort or filter your data 
according to cell or font colour, it is usually quite difficult to write formulas that take into account these 
things. Hence while it is fine to format your sheets to make them nicer for humans to look at, just make sure 
that anything that needs to be machine readable (i.e. understood by Excel or other software) is (for example, 
by including separate columns for each field as in the Party_Budget spreadsheet as needed, rather than just 
colour coding the items).  
 
Machine readability is also the reason the headings used above have underscores in them rather than 
spaces, as some software does not recognise these. If the data is just for use in Excel then there is no need 
to be so concerned about this, but if there is a chance your data may eventually be used in other software 
then you should follow the convention of using only letters, numbers, underscores and dashes in any file, 
field or header names you create. 

 
2.2 Formatting cells 

You can format cells depending on what type of information they contain or will contain. For instance, in 
columns D and F are a list of prices to one decimal place. To format these as currency select both columns 
by holding down the Ctrl button and clicking on the D and F at the same time. Then right-click anywhere in 
either of the columns and select Format Cells. You will then see a list of options to choose from, including 
General, Number, Currency, and so on. Select Currency and click OK. The numbers in both lists will now be 
formatted as dollar amounts to two decimal places.  

 
2.3 Freezing panes 

Sometimes, when you’re working with a large data set, it’s useful to be able to keep the category or heading 
panes in view as you navigate the set. To do this you will need to “freeze” the panes, which you can do by 
going to the View tab, selecting Freeze Panes and then Freeze top row. You will also see options there for 
if you wanted to freeze a selected section of cells, or freeze the first column. 
 

2.4 Resizing cells and wrapping text 
You will notice that some of the data in the sheet appears to be cut-off:  

 
 
There are a few ways to expand the columns so that the text fits. The first is to hover over the line between 
the column your text is in and the one after it (C and D in this case, as pictured below), and double-click 
when the two-way arrow comes up:  

 
 
This will expand the C column to the width of the largest piece of data (e.g. “Perth Cake Experts”). You can 
also click and drag on the two-way arrow to adjust the column to the width you want. If you have multiple 
columns that need resizing you can do them at the same time by highlighting all the relevant column headers 
(do this using Ctrl if they are not adjacent), then hovering over the end of one of the columns so that the 
two-way arrow appears and double-clicking or dragging to the desired width. You can even do this for every 
column in the sheet at once, by selecting the little triangle  in the top left hand corner of the sheet first. 
Alternatively, you can use the Format menu in the Home tab for resizing columns (and rows). 
 
Another option you can choose to display your text is to wrap it. To do this select the cells, rows or columns 
you want to wrap, go to the Home tab and in the Alignment section select Wrap Text. Now if you add more 
text to a cell it will stay at the width you have selected, but will be shown on a new line within the same cell, 
rather than being cut off/hidden.  

 
3. Autofill, flash fill and text to columns 

Excel can help save you time in many ways, including by picking up on patterns and automating processes 
for you. This section details three common ways of doing this. 
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3.1 AutoFill  
When using Excel, you may be working with data in some kind of sequence (such as counting numbers, days 
of the week, dates, etc.). You can use AutoFill to save time entering each item in the sequence into your 
spreadsheet. Test this by first adding a new sheet in the Party_Budget Excel workbook, by pressing the  
symbol at the bottom of the screen. Double-click on the new sheet name to change it (e.g. to Party_Guests). 
 
On the new sheet, enter the numbers 1 and 2 in cells A1 and A2, respectively. Highlight both cells, and 
hover your mouse over the bottom-right corner of the “2” cell. When the black + symbol shows, click and 
drag downwards to row 20. The cells will automatically be filled with the numbers 3–20.  
 
Note that this works for any sequence that Excel can distinguish in the data you have already entered (if 
you just enter a single value, it will repeat it in all the other rows). Note also that if you already have data 
entered in a certain number of rows for a column adjacent to the one you want to use AutoFill in, you can 
simply double click when you see the black + symbol rather than dragging downwards. The data will then 
be populated in the same number of rows as you have data in the adjacent column. 
 

3.2 Flash Fill 
Flash Fill is handy when you want to combine existing data to work with it more efficiently. To try this, 
type the first and last names of at least five guests you would like to invite to your party in columns B and 
C of the Party Guest sheet. Example:  

 
 
Now, in column D, type the first AND last name of the first person you are inviting (e.g. Tracy Piper) in the 
same row (e.g. row 1). Press Enter, and start doing the same for the second person in your list. As you 
begin typing the second name you should see the rest of the names automatically filled in for you in the 
remaining cells; press the Enter again and Excel will fill in the cells for you. It should look something like 
this: 

 
 
If it does not automatically fill in the cells for you, go to the Data tab and select Flash Fill in the Data Tools 
section to use Flash Fill instead.  
 
You can use Flash Fill any time you want to combine data in this way, or when you want to make the same 
change to all data in a column (e.g. appending the same text to each entry). 

 
3.3 Splitting a single column into multiple columns 

Sometimes you may want to do essentially the opposite of the above, and split a single column into 
multiple columns. For example you might already have a column containing both first and last names that 
you want to split into a column of first names and a column of last names, or you may have dates that you 
want to split into three separate columns for day, month and year. We will do the latter now, but first we 
will make a copy of the Party_Budget sheet to do it in.  
 
To do this right click on the Party_Budget tab at the bottom of the screen and select Move or Copy…, click 
on (move to end), tick Create a copy and select OK, then rename the copy Party_Budget_Copy. Now click 
in this sheet and highlight cells E2 to E19 (i.e. the dates), then select the Data tab and choose Text to 
Columns. The Convert Text to Columns Wizard will appear, where you need to specify things such as the 
type of data, how it has been separated in the current column, and where you want to place the new 
data. For this example, keep the data type as Delimited and click Next, then from the list of Delimeters 
choose Other and type the / symbol; the data preview should now show that the dates have been 
separated into three columns. Now click Next and choose the Destination for the new columns; click on 
the icon and highlight cells G2 to I19 for example, then click the icon again to select this as the 
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destination. Finally, click Finish and the dates should be separated into three columns in columns G, H, I, 
which you can give the headings of DAY, MONTH and YEAR respectively. Once you have done this, return 
to the original Party_Budget sheet. 
 

4. Sorting and filtering 
Two common ways you can organise your data are through sorting and filtering, as detailed in this section. 
 

4.1 Sorting 
Sorting your data is useful when you want to look at your data in a particular way, such as chronological or 
alphabetical order. Try this by selecting the ITEM column (A) and clicking Sort & Filter → Sort A to Z. This 
warning will pop up: 

 
 
Make sure you select Expand the selection, so that your data remains aligned with its associated variables 
(you would only ‘Continue with the current selection’ if you wanted to sort a single column and leave the 
data in any columns around it unsorted - which is not the case here). Then click Sort. The data should now 
be shown in alphabetical order. To put it back in chronological order by purchase date (as it was 
previously) do the same again, this time selecting the DATE_PAID column (E) and clicking Sort & Filter → 
Sort Oldest to Newest. 
 

4.2 Filtering 
Filtering your data is a simple way to look at similar records in your data set at the same time. 
You can do this if you have more than one record with a value the same as another (e.g. multiple items 
purchased from Woolworths). To filter your data select the column or row you want to filter by, the 
SUPPLIER column (C) for example, and in the Home tab select Sort & Filter and Filter. You should now see 
a little arrow next to the SUPPLIER cell. If you click on this you will be able to filter your data by the 
different suppliers you have purchased from, by checking and unchecking the options available. When you 
have finished, make sure you check (Select All) again. 
 

5. Formulas and simple functions 
When you want to perform calculations involving your data, you will need to make use of formulas. This 
section details how you can create your own simple formulas, as well as how you can make use of Excel’s 
in-built functions. It also covers the different types of cell references used in formulas and functions.  

 
5.1 Formulas 

You can create formulas in Excel to perform calculations, typically by referring to values in cells in your 
workbook. For example, we can add together the amounts paid and amounts owing to find the total cost 
of each item in the Party_Budget spreadsheet using formulas. We will do this in column G, which you 
should first give the heading TOTAL_COST. Now click on cell G2 and type the = sign, then either select cell 
D2 or type D2, type the + sign and finally either select cell F2 or type F2. Pressing Enter should then give 
you the total cost, which is $100 in this case. If it doesn’t, check that you have entered the formula 
correctly by clicking on the cell where you entered it (i.e. G2) and looking at the formula bar: 

 
 
You can always make edits to the formula in the formula bar if you need to.  
 

5.2 Reference types 
Something important to note when creating formulas in Excel is the different reference types. The default 
in Excel is a relative reference, meaning that any references to cells you make in your formula are relative 
to the location of the cell where the formula is. For example, the formula that we have just written is a 
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formula that refers to the cells three places and one place to the left of it respectively. If we copy and 
paste the formula in cell G3, for example, the formula adds together the values in cells D3 and F3 instead 
to give a total cost of $300. This is very useful in instances such as this, when we are wanting to perform 
the same operation for different sets of cells. Indeed, we can now copy the formula to the rest of the cells 
in the TOTAL_COST column to find the total cost of the remaining items by clicking on cell G3, hovering 
the mouse over the bottom-right corner of the cell until the black + symbol shows, and double clicking. 
 
Alternatively, if you want the formula to remain exactly the same in the new cell you are copying it to you 
need an absolute reference. You can convert to this reference type by either manually adding $ signs to 
the front of all the column and row references in the formula bar, or by highlighting it in the formula bar 
and clicking F4. Try doing this to the formula in cell G20: 

 
 
If you then press Enter and copy and paste the formula in cell I2, for example, the result should be the 
same total of $213 (delete the value in cell I2 when you have confirmed this). 
 
Finally, you might sometimes want to use a mixed reference to keep either the row or the column 
absolute, but the other relative. You can do this by typing the $ sign only in front of either the row or the 
column reference as appropriate, or by highlighting the formula and pressing F4 until you have the desired 
result. 

 
5.3 Some common functions 

For anything beyond the simple calculations described above, making use of Excel’s built-in functions in 
your formulas is a must. The following sub-sections outline a few of the most commonly used ones, but 
there are hundreds to choose from. You can find them by going to the Formulas tab and browsing through 
the lists of functions grouped into various categories, or by selecting Insert Function and searching for a 
function using a brief description. Either way, you can see details of the pieces of information (known as 
arguments) that are required to be entered as part of the function, and can click on Help on this Function 
for a detailed description of it if required. Alternatively, if you are not sure of the exact name of a function 
but know what it starts with you can type the = sign in a cell and then start typing to see a list of functions, 
which you can then select from by double clicking. You can also find a list of all functions, along with 
detailed descriptions, here: 
https://support.office.com/en-us/article/excel-functions-alphabetical-b3944572-255d-4efb-bb96-
c6d90033e188 
 
5.3.1 AVERAGE, COUNT, SUM functions 
The AVERAGE, COUNT and SUM functions are three commonly used functions when working with 
numbers. They are as follows: 
AVERAGE finds the average (mean) of values. It takes up to 255 arguments, which can be numbers, cell 
references or ranges. 
COUNT counts how many values are numbers. It takes up to 255 arguments, which can be items, cell 
references or ranges.   
SUM adds values together. It takes up to 255 arguments, which can be numbers, cell references or ranges. 
Each of these functions can be performed by typing the function as part of a formula, or by using 
AutoSum or Quick Analysis.  To type the AVERAGE function to average all the amounts paid, for example, 
first select the cell where you want the average displayed. Do this in cell D21 by typing the following (or at 
least start typing it, then double-click on the name of the function when it appears): 
=AVERAGE( 
You can then average the values in the column either by entering all the cell references as individual 
arguments or, more efficiently, by entering the range of cell references as a single argument 
(recommended). To do the latter either type D2:D20 or highlight the relevant cells; either way, the result 
when you press Enter should be $31.75 and the formula should look like this: 

 
 

https://support.office.com/en-us/article/excel-functions-alphabetical-b3944572-255d-4efb-bb96-c6d90033e188
https://support.office.com/en-us/article/excel-functions-alphabetical-b3944572-255d-4efb-bb96-c6d90033e188
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To use AutoSum to perform the COUNT function to count of the number of items that still have amounts 
owing, for example, highlight cells F2 to F20 then click on the Formulas tab, select AutoSum and choose 
Count Numbers. A count of the total number of numbers in the highlighted cells will appear in cell F21, 
although as this entire column was previously formatted as currency it appears as $4.00. To change the 
value to 4, which is the number of items still requiring some payment, simply reformat the cell as General 
using the method described previously. 
 
To use Quick Analysis to perform the SUM function to add together all of the total costs, for example, 
highlight cells G2 to G20 then click on the Quick Analysis icon in the bottom right hand corner: 

 
 
Select the Totals tab and choose Sum, and the sum of $1095.70 should appear in cell G21.  
You can edit any formulas created using AutoSum or Quick Analysis in the formula bar if needed. 
 
5.3.2 AND, IF, OR functions 
Logical functions, which check conditions and return results accordingly, are further examples of 
commonly used functions in Excel. Three examples of such functions are AND, IF and OR, which are often 
used together. Each function is as follows: 
AND checks multiple conditions at the same time. It takes up to 255 arguments, which are the conditions, 
and returns TRUE if they are all true and FALSE if they are not.  
IF makes a logical comparison and returns a value depending on the result. It takes three arguments; the 
logical expression to be evaluated (which can include AND, OR functions), the value to return when the 
expression is TRUE, and the value to return when the expression is FALSE. 
OR checks multiple conditions at the same time. It takes up to 255 arguments, which are the conditions, 
and returns TRUE if any of them are true and FALSE if they are not.  
 
As an example of using the IF and OR functions together, consider that we want to categorise the items in 
the list to see which ones were purchased from a supermarket and which were not. We will do this in 
column H, which you should first give the heading SUPPLIER_TYPE. Now click on cell H2 and type the 
following (or at least start typing it, then double-click on the name of the function when it appears): 
=IF( 
You then need to enter three arguments, the first of which is the logical test. In this case this requires use 
of the OR function, as you need to check whether the supplier is Woolworths or Coles or IGA (i.e. if it is 
any of the supermarkets). So the first argument, which you can create by typing or by a combination of 
typing and selecting cell C2, should be as follows: 
OR(C2 = "Woolworths", C2 = "Coles", C2 = "IGA") 
The second and third arguments of the IF function will then be the values you wish to return if this is TRUE 
or FALSE respectively (it will be TRUE if any of the three conditions are TRUE, and FALSE if they aren’t). So 
enter a comma and a space after your previous argument and then type “Supermarket”, a comma and a 
space, and “Not supermarket”, for example. When you press Enter the value in the cell should read ‘Not 
supermarket’, as this item was not purchased from a supermarket, and the formula should look like this: 

 
 
Copy this relative reference to the rest of the cells in the Supplier Type column to find the supplier type of 
the remaining items by clicking on cell H2, hovering the mouse over the bottom-right corner of the cell 
until the black + symbol shows, and double clicking. 
 
As another example, consider that you can use the AND and IF functions together to indicate which 
supermarket items cost more than $20. Do this in cell I2 by typing the following formula, which checks 
whether an item was purchased from a supermarket (using the new value in cell H2) and cost more than 
$20 (using the total cost in cell G2), and returns text if it was and no text if it wasn’t: 
=IF(AND(H2= "Supermarket", G2 > 20), "Supermarket item more than $20", "") 
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Again, you can copy this relative reference to the rest of the cells in column I to see the result for all items 
in the list. 
 
Finally, three variations of the IF function that may be of interest are the AVERAGEIF, COUNTIF and SUMIF 
functions. Each of these functions test if cells in a certain range (the function’s first argument) meet a set 
criteria (the function’s second argument) and average, count or sum, respectively, those that do. For 
example, typing the following formula in cell B21 will count the number of items in the list that have been 
categorised as Food in the TYPE column: 
=COUNTIF(B2:B20, "Food") 
This formula should give the result of 8. 

 
6. Transposing data 

Occasionally you might find that you wish to transpose your data; that is, change the columns of your 
spreadsheet to rows and vice versa. To do this, highlight the data you would like to transpose, (e.g. all of 
the Party_Budget data), and copy it (by right-clicking and selecting Copy or by pressing Ctrl + C). Next, 
choose where you would like to paste the transposed data (try adding a new sheet and renaming it, e.g. to 
Transposed_Data), then right-click on the cell in the top left-hand corner of where you would like to paste 
it (the A1 cell in your new sheet for example) and choose Transpose (T)  from the Paste Options. Your 
data will be transposed, with the columns as rows and the rows as columns. You just may need to resize 
the columns to fit the data, in particular to view the dates in this example (don’t worry too much about 
formatting this spreadsheet now though as we will continue to use the original Party_Budget sheet for the 
remainder of the session, so ensure you have selected it again). 

 
7. VLOOKUP 

This function can be useful when you want to look things up in a spreadsheet arranged as per the 
Party_Budget spreadsheet (i.e. with columns representing fields and rows representing records; for data 
arranged the other way around, you will need to either transpose it or to use HLOOKUP). As an example, 
consider that we want to find out the date we paid for fruit for the party. To use VLOOKUP for this we first 
need to choose the cell where the result is to be displayed. Use B22 for example, although note you 
should format this cell as a Date, using the method described previously, to ensure that the value displays 
correctly for this particular example. You may also want to type the word Fruit in cell A22, to show that 
this is the item the date refers to (you can also use this to help in step 1 below). Now click in cell B22 and 
type the following (or at least start typing it, then double-click on the name of the function when it 
appears): 
=VLOOKUP( 
You will then be prompted to enter four arguments as follows: 
1. lookup_value: this is, as the name suggests, the value you want to look up. In this case we want to 

find out the date we paid for the fruit, so “Fruit” is our look_up value. We can enter it like this (i.e. in 
quotes), or if you have typed Fruit in cell A22 then just click on that cell and the cell reference will 
appear as part of the function. 
 

2. table_array: this is the range of cells that make up the search area. This needs to include both the 
column that the function will search in for the lookup_value (column A in this case), and the columns 
to the right of it where you want it to search for the value it will return (note that VLOOKUP only 
searches columns to the right, so you will need to rearrange your data if you wish to search in a 
column to the left). Since the dates are in column E we can just use the data up to and including this 
column, and all rows from 2 to 20 (we don’t want to search our heading row) as our table_array. To 
tell Excel this, first enter a comma and a space after your previous argument (“Fruit” or A22), then 
either type A2:E20, or highlight the relevant part of the table and again the array will appear as part 
of the function for you. 

3. col_index_num: this is the column you want the function to search in for the result. The columns are 
numbered from left to right with the first column in the table_array being column 1, so since you 
want the function to search the fifth column in this case (the DATE_PAID column), you should enter a 
comma and a space after your previous argument (A2:E20) and then type the number 5. 
 

4. range_lookup: this argument specifies whether you want the VLOOKUP function to find an exact 
match for your lookup_value, or just the closest match. The default (if you don’t enter anything for 
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this argument, or if you type TRUE or 1) is for it to find the closest match, which is sometimes helpful 
in the case of numbers, but which won’t work for a text lookup_value (as in this case) unless your 
data is sorted properly in ascending order by lookup_value. Much easier is to ensure it searches for an 
exact match instead, by entering a comma and a space after your previous argument (5), and then 
typing the word FALSE. 

 
Now press Enter, and your VLOOKUP should return the result; 21/03/2019 as the date the fruit was paid 
for in this case. If it doesn’t, check that your formula looks like this: 

 
or like this: 

 
 
Note that a limitation of VLOOKUP is that if the look_up value occurs more than once, a result is only 
returned for the first occurrence. For example, typing the following formula in cell B23 will only return 
Coles as the supplier for the soft drinks, as this is the value associated with the first occurrence, even 
though they were also supplied by IGA: 
=VLOOKUP("Soft drinks", A2:E20, 3, FALSE) 
 
Another limitation is that VLOOKUP only searches for values in columns to the right of the look_up value; 
so we couldn’t look up the name of the item that cost $23.40, for example. However this issue can be 
resolved by rearranging the columns as required. 

 
8. PivotTables 

Another way you can summarise and analyse your data, this time without changing your source data, is 
through the use of PivotTables. To create a pivot table first highlight the data you wish to use; in this case 
we will highlight all data from cells A1 to F20 (alternatively, if your spreadsheet contains only source data, 
which it may in this case if you haven’t done any of the previous examples in this session, then you can click 
on any individual cell that contains data). Once you have done this, go to the Insert tab. You then have the 
option of creating a Table out of your data first before creating a PivotTable, which you should do if you 
plan to add more data later and you want to be able to automatically refresh your PivotTable afterwards 
(once you have a PivotTable you can do this by going to the Analyze tab, in PivotTable Tools, and choosing 
Refresh). If you do want to allow for this possibility, select Table and make sure the appropriate range of 
cells is selected, then click OK. You would then proceed to create a PivotTable using the instructions that 
follow. 
 
Since we are not going to be adding to our data we will instead go straight to PivotTable, where again you 
need to make sure that the appropriate range of cells is selected. You can also choose whether you want to 
create the PivotTable in a new worksheet or in a specified location in the existing worksheet; we will do the 
former, so there is no need to change the default. Instead simply select OK, and then rename the new 
worksheet Item_Types. 
 
We will first create a simple PivotTable in this worksheet listing all of the item types. To do this select TYPE 
from the list of fields on the PivotTable Fields pane on the right hand side of the worksheet (click in the 
specified area of the worksheet first if this pane is not displayed) and drag it to the ROWS area. The resulting 
PivotTable should be as follows: 
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To add a count of the number of items of each type to this PivotTable, select TYPE again and drag it to the 
VALUES area; a new column should be created in the PivotTable showing how many items were purchased 
of each type. You may also want to add a column that displays these values as a percentage; to do this select 
TYPE and drag it to the VALUES area once again, and this time right click on one of the values in the new 
column. Then choose Show Values As → % of Grand Total. The values will now display as percentages 
(alternatively, rather than adding a new column we could have just adjusted the original count column in 
this way to show percentages instead).  
 
At this point you might also want to rename the column headings so that they are more meaningful. You 
can do this by simply replacing the current headings with new headings of your choice manually, or you can 
switch to different automated headings by going to the Design tab (in PivotTable Tools), clicking on Report 
Layout and choosing either to Show in Outline Form or Show in Tabular Form. Do this now, and then also 
manually change the Count of TYPE2 heading to Percentage of TYPE. The resulting PivotTable should like 
as follows: 

 
 
Once you have created your PivotTable you can use it for further analysis if required. For example, you can 
filter the PivotTable to show the same information but for selected Suppliers; to do this select SUPPLIER 
and drag it to the FILTERS area. Then click the drop down arrow next to (All) and select one or multiple 
items to filter by (tick the Select Multiple Items box as required); try ticking Coles and Woolworths, for 
example, and check you get the following: 

 
Once you have confirmed this, change the filter back to (All) again.  
 
Alternatively, we can alter the PivotTable to show how many of each type of item come from each supplier 
by having the suppliers in the columns of the table. Before we do this, first remove the percentage column 
from the table by clicking the drop down arrow for the Percentage of TYPE field in the VALUES area of the 
PivotTable Fields pane, and selecting Remove Field. Now drag the SUPPLIERS field from the FILTERS area 
to the COLUMNS area, and the resulting PivotTable should look as follows: 

 
 
You can see the details of all items included in a particular count (or percentage) by double clicking on the 
count (or percentage) in the PivotTable. Double click on the count of 2 for Decorations, for example, and a 
new worksheet should be created showing the details of the two decorations (i.e. Streamers and Balloons). 
 
Finally, note that you can also create PivotTables using Quick Analysis by highlighting the data in a column 
or columns (excluding the header row), selecting the Tables tab and choosing an appropriate PivotTable. 
When you have finished creating PivotTables, navigate back to the Party_Budget sheet. 
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9. Creating charts 
You can create charts in Excel in a few different ways. As one example, suppose you wish to create a column 
chart to show the amount paid for each item. To do this first highlight cells A1 to A20 (i.e. the item names), 
hold down Ctrl and highlight cells D1 to D20 (i.e. the amounts paid), then go to the Insert tab and select a 
chart. Choose the first 2D column chart for example: 

 
 
A column chart will be created in the current worksheet; you can drag it somewhere else in the worksheet 
or cut and paste it in another worksheet or document if required. You will also probably need to format the 
chart; for example you can edit the title by clicking on the current title and typing a new title (Cost of Party 
Items, for example), and you can add a title to the vertical axis by clicking somewhere on the chart, clicking 
the plus sign that appears in the top right hand corner, hovering over Axis Titles, clicking on the triangle 
that appears and selecting Primary Vertical. Again, rename the title by clicking on it and typing a new title 
(i.e. Cost in Dollars). Finally, you can play around with other changes to the graph by clicking on the Chart 
Elements, Chart Styles and Chart Filters icons, or by going to the Chart tools tab if desired. Your graph 
should look something like this: 

 
 
You can also create charts using Quick Analysis. For example, suppose you wish to create another column 
chart to show the amounts paid to the different suppliers. To do this first highlight cells C2 to D20 (i.e. the 
suppliers and amounts paid), then click on the Quick Analysis icon in the bottom right hand corner, select 
the Charts tab and click on the preview of a column chart. A column chart will be created that you can 
format in the same way; the only problem is that due to the nature of the data in our worksheet, the 
different suppliers have not been grouped together. To do this, we can create a PivotChart instead. 
 
To create a PivotChart highlight all data from cells A1 to F20 as we did previously, go to the Insert tab and 
select PivotChart and PivotChart again. Check that the Table/Range is as required, and then select OK. 
Then drag the appropriate fields to the areas in the PivotChart Fields pane; in this case, drag SUPPLIER to 
the AXIS area and AMOUNT_PAID to the VALUES area. A graph should appear which displays the amount 
paid to each supplier; you can edit it as per the previous graph, and you should also reformat the values in 
the PivotTable as Currency so that the values appear as dollar amounts on the vertical axis. Your graph 
should like something like this: 
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Finally, if you wish to turn this chart into a stacked bar chart instead, to show the breakdown of item types 
for each supplier, first click on the Design tab in PIVOTCHART TOOLS, select Change Chart Type, choose a 
Stacked Column Chart and select OK. Then drag the TYPE field to the LEGEND area on the PivotChart 
Fields pane. To display this legend on the chart click somewhere on the chart, click the plus sign that 
appears in the top right hand corner and select Legend. The graph should look something like this: 

 
 
Note that you can create different kinds of charts, from pie charts to scatter plots and line graphs, in any 
of the aforementioned ways, as well as directly from an existing PivotTable by going to the Analyze tab in 
PivotTable Tools and selecting PivotChart. 

 
10. Handy Hints and Shortcuts (for PC) 

For a complete list of shortcuts (and Mac equivalents) go to https://exceljet.net/keyboard-shortcuts 
 
Format Painter 
Format painter is a handy tool that allows you to “paint” a section of text with the same formatting as 
another. The icon looks like this:       in the HOME tab.  
 
Undo last action: Ctrl Z   
If you make a mistake, press Ctrl + Z.  
 
Redo OR repeat last action: Ctrl Y  
If you want to redo something you have just undone, press Ctrl + Y. You will be taken a step forward.  

 
Insert hyperlink: Ctrl K 
The dialogue box will pop up and you can add your hyperlink as desired.  
 
Save workbook: Ctrl S 
 
Save As: F12 
This will allow you to easily save your document under a different name or in another folder.  
 
Select all cells: Ctrl A 
To select all cells in your spreadsheet, press Ctrl + A, or click on the “select all” icon, as shown below: 

 
 
Copy selected cells or text: Ctrl C 
Select the text you want to copy, and press Ctrl + C.  
 
Paste selected cells or text: Ctrl V 
Select the area you want to paste your text or object into, then press Ctrl + V.  
 

https://exceljet.net/keyboard-shortcuts
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Cut selected cells or text: Ctrl X 
You can cut the cells using Ctrl + X and then paste them to a new location using Ctrl + V 
 
Print file: Ctrl P 
 
Find a word or phrase: Ctrl F 
Press Ctrl + F. You will then be able to type in the word or phrase into the search box, and replace it if 
desired. 
 
Enter text to a new line within the same cell: Alt Enter 
The best tip I have found – allows you to have multiple lines of text entered within the same cell.  
 
Enter the current date: Ctrl ; 
Select the cell you want to enter today’s date into and press Ctrl + ; 
 
Move to last row: Ctrl ↓   
Move to top row: Ctrl ↑ 
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